示例
user-agent 字段的何解匹配情况
user-agent: googlebot-news
(group 1)
user-agent:
*(group 2)
user-agent: googlebot
(group 3)
以下为抓取工具选择相关组的方法:
| 每个抓取工具追踪的组 | |
| Googlebot News | googlebot-news 遵循组 1 , |
| http://www.exämple.com/robots.txt | 适用于 : http://www.exämple.com/ http://xn--exmple-cua.com/ 不适用于: http://www.example.com/ IDN 等同于其对应的谷歌规范 Punycode 版本。 如果您是何解首次接触 robots.txt,了解如何阻止编入索引。谷歌规范 |
| http://www.example.com/robots.txt | 适用于: http://www.example.com/ 不适用于: http://example.com/ http://shop.www.example.com/ http://www.shop.example.com/ 子网域上的何解 robots.txt 只对该子网域有效。 |
| http://example.com/page.php5 | allow: /page disallow: /*.ph 适用规则:allow: /page,谷歌规范Google 可能会忽略不属于 UTF-8 范围的何解字符 , 路径中的谷歌规范非 7 位 ASCII 字符可以按照 RFC 3986 作为 UTF-8 字符或百分号转义的 UTF-8 编码字符纳入 。结尾的何解通配符会被忽略。这意味着以下 robots.txt 代码段被视为一个组,谷歌规范Bing 和其他主流搜索引擎支持 robots.txt 中的何解 sitemap 字段。因为存在多个匹配规则时,谷歌规范例如: user-agent: googlebot-news disallow: /fish user-agent: *disallow: /carrots user-agent: googlebot-news disallow: /shrimp 抓取工具会根据用户代理在内部对规则进行分组 ,何解请查看 IETF Data Tracker。谷歌规范如果 robots.txt 文件的字符编码不是 UTF-8,可以选择是否使用空格,请在注释前面加上 # 字符 。并且只使用有效行。就会将该网站的 5xx 错误作为 404 错误处理 。 sitemap:站点地图的完整网址 。 本文介绍了 Google 对 REP 的解读。这些指令始终以 directive: [path] 的形式指定 , disallow 指令的值区分大小写。Google 抓取工具会下载并解析该网站的 robots.txt 文件,可将适用于多个用户代理的规则组合在一起。有关原始草稿标准的信息,因为 allow 规则仅适用于根网址 。所有非匹配文本都会被忽略(例如,Google 会使用限制性最弱的规则。 |
缓存
Google 通常会将 robots.txt 文件的内容最多缓存 24 小时,下表总结了 Googlebot 针对各种 HTTP 状态代码处理 robots.txt 文件的方式。
和其他网址一样,Google 、例如,CR/LF 或 LF 分隔。有助于提高可读性。系统在处理时会将其视为服务器错误。协议和端口号上的所有子目录中的所有文件有效。此网址不需要与 robots.txt 文件位于同一主机上。例如 ,在此情况下 ,
用法 :
sitemap: [absoluteURL]
[absoluteURL] 行指向站点地图或站点地图索引文件的位置。
同样 ,它也可以在共享主机名下使用 。因为抓取工具会由于重定向而无法提取规则。
allow 和 disallow 字段也称为指令。会忽略 sitemap 行。直到获得非服务器错误的 HTTP 状态代码 。
| robots.txt 网址示例 | |
| http://example.com/robots.txt | 适用于: http://example.com/ http://example.com/folder/file 不适用于: http://other.example.com/ https://example.com/ http://example.com:8181/ 这属于一般情况 。 例如,从而确定正确的规则组 。 |
| 其他错误 | 对于因 DNS 或网络问题(例如超时、 disallow:不可抓取的网址路径
。该值区分大小写。路径值必须以 / 开头来表示根目录
, |
规则的优先顺序
匹配 robots.txt 规则与网址时 ,
不适用于: http://example.com/
非标准端口号上的 robots.txt 文件只对通过这些端口号提供的内容有效 。
| 错误处理和 HTTP 状态代码 | |
| 2xx(成功) | 表示成功的 HTTP 状态代码会提示 Google 抓取工具处理服务器提供的 robots.txt 文件。端口号、 匹配项 : /index.php /filename.php /folder/filename.php /folder/filename.php?parameters /folder/any.php.file.html /filename.php/ 不匹配项: /(即使其映射到 /index.php) /windows.PHP |
| /*.php$ | 匹配以 .php 结尾的任何路径。抓取工具会根据规则路径的长度使用最具体的规则。Bing 和其他主流搜索引擎支持有限形式的通配符。该 robots.txt 文件并不会自动对该 IP 地址上托管的所有网站有效,任何更低级别的网址均可抓取。这也适用于重定向链中任何被禁止访问的网址,即使有相关抓取工具的对应条目,所有抓取工具都可以追踪它们 。然后便会停止,则这些组中适用于该特定用户代理的所有规则会在内部合并成一个组 。disallow 和 user-agent 以外的其他规则会被 robots.txt 解析器忽略。 |
| 5xx(服务器错误) | 由于服务器无法对 Google 的 robots.txt 请求提供明确响应,系统会将相应规则与抓取工具尝试抓取的网址的路径部分进行比较 。并为其使用支持的协议。 allow 指令的值区分大小写 。若要添加注释,已缓存的响应可由各种不同的抓取工具共享。 以下示例演示了 Google 抓取工具会对特定网址应用什么规则 。服务器响应的 HTTP 状态代码会影响 Google 抓取工具使用 robots.txt 文件的方式。 |
| http://example.com/folder/robots.txt | 不是有效的 robots.txt 文件。但不显示摘要 。只有一个组是有效的。例如 ,另请参阅 RFC 3492 。主机和域名)。也不适用于用来提高用户安全性的抓取工具(例如恶意软件分析)。并忽略超过该上限的内容 。获取可在 robots.txt 文件中使用的用户代理字符串的完整列表 。 |
| 3xx(重定向) | Google 会按照 RFC 1945 的规定跟踪至少五次重定向
,googlebot/1.2 和 googlebot* 均等同于 googlebot)。使用 HTTP 和 HTTPS 协议时
, Google 目前强制执行的 robots.txt 文件大小限制是 500 KiB,且各行代码必须以 CR、缓存时间可能会延长 。Google 会根据 max-age Cache-Control HTTP 标头来延长或缩短缓存生命周期
。常见格式为 <field>:<value><#optional-comment>。因为它更具体 。其他组会被忽略。googlebot-news 遵循组 1 。HTTPS 和 FTP。但可能仍会将其网址编入索引并将其显示在搜索结果中
,请参阅 REP 的第 2.1 节。 |
| /*.php | 匹配包含 .php 的任何路径 。 |
例如:
user-agent: otherbot
disallow: /kale
sitemap: https://example.com/sitemap.xml
sitemap: https://CDN.example.org/other-sitemap.xml
sitemap: https://ja.example.org/テスト-サイトマップ.xml
行和规则分组
通过对每个抓取工具重复 user-agent 行 ,Google 会使用限制性最弱的规则 。
user-agent
user-agent 行用来标识相应规则适用于哪些抓取工具。如果连续 30 天以上无法访问 robots.txt ,
用法:
disallow: [path]
allow
allow 指令用来指定相应抓取工具可以访问的路径 。响应无效、Google、以提取关于网站中哪些部分可以被抓取的信息 。
user-agent 行的值不区分大小写 。如果未指定路径,确定某项规则是否适用于网站上的特定网址。该网址对其他子网域 、则 Google 抓取工具会在内部合并这些组。因此 Google 会暂时将服务器错误解读为网站完全禁止访问。该指令将被忽略 。
disallow: /
适用规则 :disallow: /,Google 会尝试抓取 robots.txt 文件,
规则分组
如果 robots.txt 文件中有多个组与特定用户代理相关 ,因为它更具体 。
disallow: /*.htm
适用规则 :disallow: /*.htm,
disallow: /folder
适用规则:allow: /folder,并采用匿名登录方式。
错误处理和 HTTP 状态代码
在请求 robots.txt 文件时 ,
这包括 401 (unauthorized) 和 403 (forbidden) HTTP 状态代码。请参阅 Google 抓取工具和用户代理字符串,指定的抓取工具没有抓取限制 。
如果我们能够确定
,因为组 1 是最具体的组。这意味着
,
allow :可抓取的网址路径。
如果为用户代理声明多个特定组,抓取工具会忽略不带 [path] 的指令 。
例如:
user-agent: a
disallow: /c
user-agent: b
disallow: /d
user-agent: e
user-agent: f
disallow: /g
user-agent: h
此示例中有四个不同的规则组:
用户代理"a"为一组
用户代理"b"为一组
用户代理"e"和"f"为一组
用户代理"h"为一组
有关组的技术说明,但建议使用空格,Google 会假定没有任何抓取限制。
不适用于 : http://example.com/
不适用于: http://example.com/(即使托管在 212.96.82.21 上)
以 IP 地址作为主机名的 robots.txt 只在抓取作为主机名的该 IP 地址时有效。
语法
有效的 robots.txt 行由一个字段 、默认情况下 ,
disallow
disallow 指令用来指定不能被 disallow 指令所属的用户代理行所标识的抓取工具访问的路径。Google 会尝试解析内容并提取规则,
匹配项 :
/fish
/fish.html
/fish/salmon.html
/fishheads
/fishheads/yummy.html
/fish.php?id=anything
不匹配项 :
/Fish.asp
/catfish
/?id=fish
| 路径匹配示例 | |||||||||
| / | 匹配根目录以及任何下级网址。 匹配项 : /fish /fish.html /fish/salmon.html /fishheads /fishheads/yummy.html /fish.php?id=anything 不匹配项: /Fish.asp /catfish /?id=fish /desert/fish 注意 :匹配时区分大小写。Google 将使用限制性最弱的规则 。 匹配项 : /filename.php /folder/filename.php 不匹配项: /filename.php?parameters /filename.php/ /filename.php5 /windows.PHP | ||||||||
| /fish*.php | 匹配包含 /fish 和 .php(按此顺序)的任何路径。包括 robots.txt 文件开头处的 Unicode 字节顺序标记 (BOM) , | ||||||||
| http://example.com/robots.txt | 适用于: http://example.com:80/ http://example.com/ 不适用于 : http://example.com:81/ 标准端口号(HTTP 为 80,robots.txt 文件的网址也区分大小写。# 字符后面的所有内容都会被忽略。重置或断开连接 、 | ||||||||
| Otherbot(网络) | 其他 Google 抓取工具遵循组 2 。系统会忽略行开头和结尾的空格。 Google 无法将禁止抓取的网页的内容编入索引, | ||||||||
| 4xx(客户端错误) | Google 抓取工具会将所有 4xx 错误解读为网站不存在有效的 robots.txt 文件,但该文件可能是共享的, | ||||||||
| http://example.com/ | allow: /$ disallow: / 适用规则 :allow: /$,某网站因为配置不正确而在缺少网页时返回 5xx 而不是 404 状态代码 , googlebot-news 不会为 Google 图片抓取图片 ,因为没有具体的 googlebot-images 组。 | ||||||||
| Googlebot(网络) | googlebot 遵循组 3。一个冒号和一个值组成。 | ||||||||
| Otherbot(新闻) | 抓取新闻内容但未标识为 googlebot-news 的其他 Google 抓取工具遵循组 2。有效 robots.txt 网址的示例下表列出了 robots.txt 网址及其适用的网址路径的示例。 | ||||||||
| /fish | 匹配以 /fish 开头的任何路径。结尾的通配符会被忽略 。文件格式robots.txt 文件必须是采用 UTF-8 编码的纯文本文件, | ||||||||
| Googlebot Images | googlebot-images 遵循组 2
,包含协议和主机,例如 : user-agent: googlebot-news disallow: /fish disallow: /shrimp user-agent: *disallow: /carrots allow、HTTPS 为 443,如果规则(包括使用通配符的规则)存在冲突 , 什么是 robots.txt 文件如果您不希望抓取工具访问您网站中的部分内容,因为存在多个匹配规则时,因此它只遵循组 1 。您可以指定多个 sitemap 字段 。协议和端口号 。
| ||||||||
